lunedì, aprile 21, 2008

Chkdsk /r ...

Questo fine settimana son tornato a Siracusa con un pensiero per la testa ... il PC fisso!
Mia moglie mi aveva preannunciato che accendendolo veniva fuori il simpatico messaggio:
"Reboot and select proper boot device, or insert Boot Media in selected boot device and press a key".
Fra me e me pensavo ... magari non e' niente, non si sara' rotto l'hard-disk, forse per qualche oscuro motivo si e' rovinato il master boot record ...
Questo non potevo saperlo in anticipo, dovevo vedere.
Sabato mattina mi son messo all'opera. Accendo il PC ... messaggio d'errore ...
Ok, proviamo entrando nella Recovery, probabilmente basta eseguire:

1 - FIXMBR
2 - FIXBOOT

e perche' no:

3 - BOOTCFG / REBUILD

Per i punti 1 e 2 nessun problema ... il terzo invece:
ERRORE: impossibile aggiungere ... etc etc ... pardon, non ricordo il messaggio preciso, la questione era semplice pero', non riusciva a riscrivere il file boot.ini.

A quel punto ho controllato la salute del disco. Ho usato il comando nel titolo:

CHKDSK /R

E' riuscito a correggere alcuni errori sul disco ... ma questo non ha risolto il problema ... cosa avreste fatto al posto mio? Ebbene si ... ho pensato di formattare!
Adesso la faccio breve, ma ho perso tutto il sabato mattina ed anche un bel po' di ore la domenica per cercare una soluzione. Son fatto cosi' ... dovevo capire il perche' ... e questo mi avrebbe portato alla soluzione ...
Comunque, alla fine rassegnato ho riavviato il PC con il CD Live di Ubuntu 7.10, ho fatto il backup di tutti i dati ed ho riavviato con il CD di Windows XP (in quel PC mi serve Windows ...).
Procedo con le varie fasi ed arrivato al punto dove scegliere la partizione su cui installare il sistema noto una cosa moooolto strana:
L'hdd interno che uso come backup ha una partizione di 8 mega byte non formattata ... strano! La formatto, riavvio ... ed il messaggio d'errore cambia.

Ecco dove sta il problema!!!

E' colpa dell'hdd di backup! Per qualche oscuro motivo (davvero, oscuro) l'hdd di backup e' diventato master.
Smonto il PC, stacco l'hdd di backup e magicamente il sistema riparte!

Morale della favola: non ho formattato! E di questo ne son molto contento!

(... pensare di rimettere su tutto ... mamma mia, meglio non pensarci ...)

Mi rimane l'ultimo dubbio: perche' il sistema fino ad oggi ha funzionato? Forse quando (molto tempo fa) giocherellavo con le partizioni qualcosa e' andato storto? Boh ... indaghero' meglio.

Per la cronaca: l'hdd dove e' installato il sistema e' SATA, quello di backup e' IDE, forse devo forzare l'IDE come slave ... provero' ...

[fonte fotografia]

Etichette: , , ,


Condividi questo Articolo:   Bookmark and Share

9 Commenti:

Blogger Grizzly said...

Uhm... una considerazione: se sull'hard disk principale c'e' un qualche boot loader (lilo, grub, bsd*loader o simili) e cambia la geometria e/o la funzionalita' di uno qualsiasi degli hard disk presenti, succedono fenomeni del genere.
Altro fattore che puo' influire, e' il ritardo nel riconoscimento dell'hard disk serial ata ("Delay for Hard Disk" su alcuni bios), perche' puo' bastare un paio di secondi di ritardo nell'ottenere risposta dall'unita' perche' la stessa venga automagicamente trasmutata in secondary da che era primary...

.... io invece ancora non ho capito perche' sul server ogni tanto vivo una bella inversione delle due interfacce di rete eth0 ed eth1...

22/4/08 9:21 AM  
Blogger Francesco said...

@grizzly: lilo, grub, bsd*loader o simili no, non c'e' ne' ... forse e' stata colpa di un tool che eseguiva il controllo del disco all'avvio che poi ho disinstallato.

Non lo so ... pero' il discorso del ritardo sul serial ata e' probabile ...

Comunque, prima o poi penso di formattare lo stesso, devo sistemare le partizioni.

Grazie Grizzly ;)

22/4/08 9:39 AM  
Blogger yuri said...

vi mettete come miei sostenitori su yututtocomputer.blogspot.com e io mi metterò come vostro sostenitore. ciao grz vi stimo

12/7/09 8:05 PM  
Blogger Luciano said...

A me succedeva quando avevo un vecchio disco IDE connesso al pc con il S.O. sul raid SATA,se spengevo il pc con inserita una chiavetta USB o disco rimovibile; al riavvio resettava l'ordine di boot e metteva il disco IDE come primo....e ovviamente, "reboot and insert proper boot device"....

19/2/10 7:22 PM  
Blogger Francesco said...

@Luciano: grazie per il commento. E' probabile che sia successo qualcosa di simile anche nel mio caso, ma non e' detto.

Ricordo che (come scrissi poi qui) si erano resettate non solo le priorita' sul boot, ma anche altre impostazioni nel bios. Risistemate le impostazioni il problema non si e' presentato piu'. Credo che all'epoca sia stato uno sbalzo di tensione a provocare lo sfasamento, non ho nemmeno cambiato la batteria sulla scheda ... cmq, mi son dilungato abbastanza :)

Ancora grazie per esser passato ed aver lasciato la tua esperienza ;)

20/2/10 6:41 PM  
Anonymous Anonimo said...

Domanda stupida.
Non è ce per caso è stato inserito un floppy non avviabile nell'unità floppy?

30/12/10 10:27 AM  
Blogger Francesco said...

@Anonimo: No no, come ho gia' spiegato nei commenti precedenti si era resettato il bios per uno sbalzo di tensione. Grazie di esser passato ;)

4/1/11 9:11 AM  
Blogger adam said...

credo di avere lo stesso problema sul mio pc. ho spento tramite on/off e xp non riparte più, anche a me riporta 2 partizioni di cui una di 8 mb, che faccio? formatto sta partizione e riavvio? mi fate gentilmente sapere, grazie.

24/6/11 7:43 PM  
Blogger Francesco said...

@adam: no, non c'e' bisogno di formattare la partizione da 8 mega. Probabilmente ti si e' corrotto solo il MasterBootRecord. Prova a ripristinare Windows con il cd di installazione.

24/6/11 8:58 PM  

Posta un commento

Io sono per la comunicazione libera senza blocchi, ma dato che comunque questo e' il mio spazio personale e personalmente non sopporto chi commenta usando un linguaggio volgare mi vedo costretto a moderare i commenti.
Abbiate pazienza.

Links to this post:

Crea un link

<< Home